# ウィジェットを設定する

データソース、絞り込み、表示設定を変更し、必要な情報を表示します。

Source: https://support.toolingmetrics.com/ja/analytics/guides/configure-widget/
Updated: 2026-10-29

**前提条件：** 少なくとも1つのウィジェットがあるダッシュボードが存在すること。

**必要な権限：** レポート → ダッシュボード — ユーザー以上（自分が作成したダッシュボード）。管理者はすべてのダッシュボードのウィジェットを設定できます。

<a id="open-widget-settings"></a>

## ウィジェットの設定を開く

1. 対象のウィジェットがあるダッシュボードを開きます。
1. ウィジェットのカードにポインターを合わせ、メニューの**設定**をクリックします。

設定パネルには**表示**、**データ**、**絞り込み**の3つのタブがあります。

<a id="set-the-source-and-columns"></a>

## データソースと列を設定する

1. **データ**タブの**データソースの種類**をクリックし、在庫品目、セット工具、切れ刃、機械、保管設備、倉庫、購入注文、購入注文明細、使用原価明細、工具寿命から読み取るレコードの種類を選びます。**指標**ウィジェットが読み取れるのは機械、保管設備、倉庫だけです。種類が指標の間は、ほかの種類は表示されません。
1. 表示タブの**種類**が**指標**の場合、**データソース名**で特定のレコードを選びます。指標ウィジェットは1つのレコードから列を読み取るため、選択するまで表示できません。グラフと表の場合は**すべてのレコード**のままにします。この種類では項目を変更できません。
1. **列**で各項目の関数を選びます。分類する列には**グループ**、集計する値には**合計**、**件数**、**平均**を指定します。例えば使用原価明細で、**機械**＝**グループ**、**原価**＝**合計**、**計上日**＝**月ごとに集計**とすると、「機械別・月別の原価」を確認できます。選択できる関数は列の種類により異なります。[列の関数](https://support.toolingmetrics.com/ja/analytics/reference/widgets/#column-functions)を参照してください。
1. 必要に応じて**並び替え項目**と**並び順**を設定し、表示タブの**上限**で行数や系列数を制限します。

<a id="apply-filters"></a>

## 絞り込みを設定する

1. **絞り込み**タブの**条件の結合方法**で、追加した条件行の**すべて**に一致させるか、**いずれか**の1つに一致させるかを選びます。
1. **+**ボタンで条件行を追加し、列、演算子、値を選びます。「過去n日間」は日時列のみで選択でき、値の入力欄が日付選択から日数入力に変わります。演算子の一覧は[絞り込み](https://support.toolingmetrics.com/ja/analytics/reference/widgets/#filters)を参照してください。

<a id="set-the-display"></a>

## 表示を設定する

1. **表示**タブで、**タイトル**、**サイズ**、**種類**を設定します。種類は**指標**（1つのレコードの項目値をカードで表示）、**グラフ**、**表**です。
1. **種類**が**グラフ**の場合、**グラフの種類**を折れ線グラフ、縦棒グラフ、面グラフ、散布図、横棒グラフ、円グラフ、積み上げ縦棒グラフ、積み上げ横棒グラフ、積み上げ面グラフから選びます。
1. 必要に応じて**更新間隔**を秒単位で設定し、データを自動更新します。

<a id="save"></a>

## 保存する

**更新**をクリックします。ウィジェットはすぐに保存されます。別途ダッシュボードに反映する操作は必要ありません。

<a id="troubleshooting"></a>

## トラブルシューティング

**「表示できるデータがありません。」と表示される場合**
指標ウィジェットで**データソース名**が「すべてのレコード」のままだと、読み取るレコードがありません。1件を選択してください。それ以外の場合は、絞り込みやグループ化に一致するデータがあるか確認します。

**「このウィジェット設定は表形式に対応していません。」と表示される場合**
表はグループ化・集計済みの結果を表示できません。その列の組合せでは、**種類**をグラフまたは指標に変更してください。

**赤いエラーメッセージが表示される場合**
絞り込みや列の組合せにより、データ取得時にエラーが発生しています。例えば、絞り込みの値が対応していない場合です。「データの取得中にエラーが発生しました:」に続く内容で原因を確認し、データまたは絞り込みタブを修正してください。
