コンテンツにスキップ
言語の選択:日本語
テーマの選択

ウィジェットを設定する

データソース、絞り込み、表示設定を変更し、必要な情報を表示します。

更新日:

前提条件: 少なくとも1つのウィジェットがあるダッシュボードが存在すること。

必要な権限: レポート → ダッシュボード — ユーザー以上(自分が作成したダッシュボード)。管理者はすべてのダッシュボードのウィジェットを設定できます。

  1. 対象のウィジェットがあるダッシュボードを開きます。
  2. ウィジェットのカードにポインターを合わせ、メニューの設定をクリックします。

設定パネルには表示、データ、絞り込みの3つのタブがあります。

  1. データタブのデータソースの種類をクリックし、在庫品目、セット工具、切れ刃、機械、保管設備、倉庫、購入注文、購入注文明細、使用原価明細、工具寿命から読み取るレコードの種類を選びます。指標ウィジェットが読み取れるのは機械、保管設備、倉庫だけです。種類が指標の間は、ほかの種類は表示されません。
  2. 表示タブの種類が指標の場合、データソース名で特定のレコードを選びます。指標ウィジェットは1つのレコードから列を読み取るため、選択するまで表示できません。グラフと表の場合はすべてのレコードのままにします。この種類では項目を変更できません。
  3. 列で各項目の関数を選びます。分類する列にはグループ、集計する値には合計、件数、平均を指定します。例えば使用原価明細で、機械=グループ、原価=合計、計上日=月ごとに集計とすると、「機械別・月別の原価」を確認できます。選択できる関数は列の種類により異なります。列の関数を参照してください。
  4. 必要に応じて並び替え項目と並び順を設定し、表示タブの上限で行数や系列数を制限します。

  1. 絞り込みタブの条件の結合方法で、追加した条件行のすべてに一致させるか、いずれかの1つに一致させるかを選びます。
  2. +ボタンで条件行を追加し、列、演算子、値を選びます。「過去n日間」は日時列のみで選択でき、値の入力欄が日付選択から日数入力に変わります。演算子の一覧は絞り込みを参照してください。

  1. 表示タブで、タイトル、サイズ、種類を設定します。種類は指標(1つのレコードの項目値をカードで表示)、グラフ、表です。
  2. 種類がグラフの場合、グラフの種類を折れ線グラフ、縦棒グラフ、面グラフ、散布図、横棒グラフ、円グラフ、積み上げ縦棒グラフ、積み上げ横棒グラフ、積み上げ面グラフから選びます。
  3. 必要に応じて更新間隔を秒単位で設定し、データを自動更新します。

更新をクリックします。ウィジェットはすぐに保存されます。別途ダッシュボードに反映する操作は必要ありません。

「表示できるデータがありません。」と表示される場合 指標ウィジェットでデータソース名が「すべてのレコード」のままだと、読み取るレコードがありません。1件を選択してください。それ以外の場合は、絞り込みやグループ化に一致するデータがあるか確認します。

「このウィジェット設定は表形式に対応していません。」と表示される場合 表はグループ化・集計済みの結果を表示できません。その列の組合せでは、種類をグラフまたは指標に変更してください。

赤いエラーメッセージが表示される場合 絞り込みや列の組合せにより、データ取得時にエラーが発生しています。例えば、絞り込みの値が対応していない場合です。「データの取得中にエラーが発生しました:」に続く内容で原因を確認し、データまたは絞り込みタブを修正してください。